Sentre
Search…
Troubleshoots

ERR_OSSL_EVP_UNSUPPORTED

Problem

New Open SSL is not compatible with the legacy. This issue used to occur on NodeJS versions greater than 14.
1
Error: error:0308010C:digital envelope routines::unsupported
Copied!

Resolve

Change the start command to:
1
craco --openssl-legacy-provider start
Copied!

NODE_ENV is not recognized

Problem
The NODE_ENV is not available for Node on Window.
1
'NODE_ENV' is not recognized as an internal or external command, operable program or batch file.
Copied!
Resolve
Install win-node-env by the command:
1
npm install -g win-node-env
Copied!